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VMD - continued: Making Movies

(This section can be used immediately after Desktop Molecular Graphics)

VMD (http://www.ks.uiuc.edu/Research/vmd/) is a free program developed at the
Theoretical and Computational Biophysics Group at the University of lllinois at Urbana-
Champaign for the visualization and animation of biological (macro) molecules. See also
http://www.scripps.edu/rc/training/unixslides/vmd.pdf

LABORATORY EXERCISES

1 -VMD-Exercise H: Starting VMD and opening a molecule

V OPTIONAL

This exercise summarizes the methods seen in the Desktop Molecular Graphics section.

* Double click on the VMD icon or select it within the task-bar.
« On the “VMD Main” window menu select “File > New Molecule...” this
will open the “Molecule file browser.
o Click the “Browse” button to select a PDB file in your folder within yet another
window. — For example use “hrv2-3C-1CQQ.pdb” - Click “Open”
o Click “Load”
* The selected PDB file is now loaded within VMD
* VMD Main: Graphics > Representations
* Click on the “Create Rep” button
a. Create Rep (button)
b. Within the “Selected Atoms” Edit one representation to “protein”
c. Edit the other to “not protein”
* Resize the VMD OpenGL display to the size you want your movie. Don’t
make it too large and don’t make it too small either.
* Using the mouse highlight the “Rep” selection of the “not protein”
o Coloring Method: Name
o Drawing Method: Licorice
* Using the mouse highlight the “Rep” selection of the “protein”
o Coloring Method: Pos
o Drawing Method: Surf
* Orient your image, this will be the start position for the movie.
* Change the background to white if you wish:
o VMD Main: Colors > Display > background > white
* VMD Main: Display > Orthographic
* VMD Main: Display > Depth Cue

o ‘\Yp o
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2 VMD-Exercise I: Making movies with VMD

V INFO - Prerequisites: making movies with VMD requires that other software
packages be installed. The DMC classroom is already set-up for using the VMD
movie-making scripts. The Unix/MacOSX solution is free while the windows version
requires the installation of the VideoMach shareware package. Some installing
information is given at the end of this tutorial.

As of this writing the relevant information is located on the VMD web site at

http://www.ks.uiuc.edu/Research/vmd/plugins/vmdmovie/

However: even if the required software for making movies is not installed on your
computer, VMD will nevertheless make all the individual frames that can later be
assembled into a movie, for example with Apple’s QuickTime™ Pro (Macintosh and
Windows) or a shareware such as Animagic (Windows) or freeware GIMP (Unix,
Mac OS X) to make animated GIF.

000 = VMD Movie Generator —
V TASK M_H‘M Renderer [3) | Movie Settings 13 Format [3) " Help |
Analysi » © Set working directory: ) /
* within the “VMD Main” window {Bocore > P —
= Data » Name of movie: [untitied
SeIeCt the “EXtenSIons > MOdeIIng 4 Number of frames to render: |180
: . ) phi
Visualizations> Movie Maker” [ e T
i H * Tk Consol Clipping Plane Tool tage: 0 o
menu. This will open the “VMD A Cor sectoar || rms oo

Movie Generator” interactive — O
window.
* Verify the settings in the 3 pull-down menus within Renderer 31 Movie Settinas
“ : ” v Snapshot (Screen Capture)
VMD Movie Generator “ " Internal Tachyon (Ray Tracer)
o Render: Should set on “Snapshot Tachyon (Ray Tracer)

POV-Ray (Ray Tracer)

Note: if this option creates strange images (most possible under
Windows) change to “Internal Tachyon” which is slower but would work.

o Movie Settings: To make a rotation of the Movie Settings [+ [ Format 15 [+
1] » v Rock and Roll (XY lemniscate)
molecule change the “Rock and Roll T EETT
setting to “Rotation about Y axis.” Trajectory

Trajectory Rock

1: Image smoothing

Note: if you want to keep the frames, then uncheck the - ralisbErecaling
“4: Delete image files” as illustrated. 3: Text labelling

v 4: Delete image files
Text label settings...

o Keep the preselected “MPEG-1” selection | “Format %1 Help 21l
Animated GIF (ImageMagick)

i : . WA s JPEG frames (ImageMagick)
Note: if you want to place your movie on a web site select “Animated Targa frames (ImageMagick)

GIF” but note the animated GIF files are larger than MPEG-1 files. v MPEG-1 (ppmtompeg)
Change Compression Settings.
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* Set working directory: the default
working directory is “/’ (also called
“root”) which would be the main hard
drive on Mac OS X often named
“Macintosh HD” this is where movies
and frames are saved.

o If you want to change the
working directory somewhere on
the “Desktop” click on the button
“Set working directory”

Click “Users”

Click “BNMC”

Click “Desktop”

Click “New Folder”

Name your folder “My Movie”

Click “Create”

Your working folder is now set on

the desktop
Note: On Windows systems the desktop is available
within the C:\Windows directory

O O O O O O O

“ Set working directory: ’ /

Choose working directory for temp files

From: | [@§Desktop [ ]

= Macintosh HD » er Lc
@ Network » L5 ysFiles
# Library
L sw
System
System Folder
& Users vy
.
(" New Folder ) __Add to Favorites )
Go to:
@ Administrator Adobe SVG 3 Loc
»
® Guest [@ Desktop
Documents P
@ Student » o
£ Shared # Library
8| membrane.pc i
¥ mem I: v

New Folder

Name of new folder:

My Movie

( cancel ) (m)

* Name your movie “movie-1” or
choose a name you like.

* Set the number of frames to 36 if you
are making a “Rock and Roll” movie,
otherwise set this number to 360 if you
selected earlier “Rotation about Y
axis” (the default is 180).

Name of movie: movie-1

Number of frames to render: |B6

* Make your movie: Press the “Make
movie” button.

You can watch the progress of the movie
making on the “VMD Display” as well as on
the “VMD Movie Generator” window by
looking at the “Status,” “Stage,” and
“Progress” information provided.

Note: The 360 Y-rotation takes a few minutes
since there are more frames. If you made a
mistake you can click “Abort” and reset your
parameters. The temporary files will be

Number of frames to render: |360

Status: Rendering
Stage: 2 of 8

Progress: 25 of 360

‘ Make Movie ) [ Abort |

discarded automatically. . _
VU

VMD - page - 147




Biochem 660 — 2008 148

3 -VMD-Exercise J: Finding and viewing your movies

a. Finding your movies:

The movies are created within the “working directory” which you have set earlier.
If you have not set the working directory your movie will be in the default working
directory of “/” which is the main hard drive on a Mac OS X computer. If you still
don’t know or cannot find your movie use the menu “File > Find...” (Macintosh) or
“Start > Find Programs and Files...” (Windows) and search for the movie name
you have given, e.g. “My Movie.”

b. Playing your movies:

The movies will have either a .gif or .mpg attached to the name you had given.
However depending on the settings of the computer you are using these filename
extensions may not be visible. These filename extensions are a way for your
computer to know the format of these animations and will warn you if you try to
delete them.

Playing MPEG-1 files: your default multimedia player should automatically play
the MPEG-1 files. Your default player is likely to be “QuickTime™” on an Apple
computer and “Windows Media Player” on a Windows system.

Playing animated GIF files: animated GIF files may play within your default media
player just like the MPEG-1 files, but you may have to use the “File > Open...”
menu sequence to open it. Animated GIF files play well within web browsers
(Netscape, Internet Explorer, Safari, Mozzilla etc.).

c. Using your movies:

MPEG-1 files can be used for presentation or inserted within a PowerPoint
presentation to illustrate your molecule. MPEG-1 images can also be made a part
of a web page, however the viewer will need the appropriate plug-in (to see the
movie within the browser) or appropriate media player (the movie will be
downloaded and played).

Animated GIF files can be used as an image on the web. Inserted as a regular
GIF image file it will still be an animation. The advantage is that this does not
require any plug-in for the viewers to see your animation as it is the case for
QuickTime, MPEG or FLASH animatipr(l\s\y./] "
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4 -VMD-Exercise K: Movies from NMR multiple PDB files

Usually NMR structures are published as both a series of 10 to 20 possible
models, as well as an “average” model. The average structure contains a single
set of PDB coordinates, while the other file contains a series of PDB structures
within the same file. Each structure starts with the PDB record “MODEL  #”
(where # is a number) and ends with “ENDMDL” record line. Some software can
sometimes only see the first model in a multiple file, others can be used to
animate them. Here we will animate a file containing 20 models with VMD.

V TASK

1) open VMD and load PDB file 1INYZ.pdb | Note: as the molecule opens
a. VMD Main: File > New Molecule | you can notice it “wiggle” as the
b. Browse... (find INYZ.pdb in 20 models are loaded.
window)
c. Open
d. Load
2) VMD Main: Display > Orthographic
3) VMD Main: Graphics > fn
Representations B e

a. Coloring Method: ColorlD 5 [Coborio — ~][s ~][Opaque <]

b. Drawing Method: Licorice |f’7wc§—”% e

c. Create Rep button This command selects residue

d. Edit new rep to “resid 19” 19 (a U) to be represented

e. Coloring Method: ColoriD 3 differently than the rest of the

f. Drawing Method: Licorice molecule, here ColorID 3 is
orange. You can select an
other color scheme, e.g. 6
(gray) for the RNA and 1 (red)
for U19. You can also make the
background white if you wish.

Note: “resid” keyword is different than “residue” keyword.
First residue is internally renamed residue 0 (zero) by VMD.

Therefore to select residue 19 we would have to select “residue
18” ... or simply “resid 19”
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4) Scale the image within the window and
orient it so that residue 19 is on your
right, showing its stacking position, in a
side-way view.

5) VMD Main: Extensions > vmdmovie

6) Set parameters within VMD Movie Generator top
menus:
a. Render: Snapshot (screen capture) e Ces 1
b. Movie Settings: Rt shout s
i. Trajectory Trajectory Rock
ii. Uncheck 4: Delete image files e
¢. Format: MPEG- e
7) Set parameters within the rest of the window: Text label settings...

a. Set working directory: create a folder on the
desktop and name it e.g. NMR

b. Name of movie: u19 (.mpg will be appended
automatically)

c. Number of frames to render: 20 (default,
because there are 20 models)

8) Click Make Movie button

9) The movie will be saved within the working directory Note: the movie

(NMR), you can double click on it, it should speed is about
automatically open within QuickTime Player in the 30 frames per
BNMC classroom. second.

10)You can engage the menu “Movie > Loop” to have it
loop continuously.

11)If you inspect the NMR directory, you will see two series of image frames:
the original *.rgb or tga frames and those converted to *.ppm by
ImageMagick in the background.

Note: PDB entry 1INYZ has now been replaced by 1SY4
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V INFO - Supplemental Information: Installing software pre-requisites for
movie making with VMD 1.8.x on Mac OS X. You will need to have administrator
privilege (password) to accomplish this.
1) X11 is automatically present on newer OS X versions (starting with 10.5)
2) Download “Fink” from http://fink.sourceforge.net/download/ :
Download Fink Binary Installer for current version for later OS.
Help is available at http://homepage.mac.com/saol/fink/#top8

Although there is a graphical interface (“Fink Commander’), for sake of simplicity
the following will describes the line command method of installation of binaries:

3) Launch a “Terminal”’ (located in Macintosh HD : Applications : Utilities :
Terminal)
4) Within the terminal type the following commands a the % or $ prompt:
. % fink selfupdate-cvs
. % fink install system-xfree86
. % fink list
. % sudo apt-get install imagemagick-nox
. % sudo apt-get install netpbm
% rehash

This should install all the necessary binary files for making movies from VMD.
Note that you will be asked a password for administrative privilege, and that more
binaries dependences may be installed at the same time.

Note for Windows users from the VMD script home page
http://www.ks.uiuc.edu/Research/vmd/plugins/vmdmovie/

On Windows, the program VideoMach is currently required for all movie
generation tasks. It is a shareware program and is available for trial
download from the VideoMach web site. Registration costs $19 for non-
commercial use, and $49 for commercial use."

Note: the Videomatch web site is at
http://www.gromada.com/videomach.html

- End of VMD Movie -

o ‘\Yp o
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